Emergency in France…..

Electrical Failure on French Motorway

As you may have seen in my last post, it rained quite heavy whilst we were at Disneyland and although it has abated slightly when we departed, we had a very interesting journey home.

When negotiating the exit slip road from the A104 onto the A1, we encountered flooding which we had no choice but to drive through after all, cars were seeming to get through OK.

Everything was OK until it started raining again and we realised we had no wipers, then we had no lights, then we had no anything……

As it is diesel, we were still running and we continued of a while until the rain dictated otherwise and we pulled into a motorway aire to see what the problem was.

We had plenty of time to get to Calais or so we thought.

I suppose my mistake was stopping the engine – it would not restart afterwards which I knew but still did it anyway!

We quickly found an on-line manual showing all the fuseboxes (3 of them in total) so where was our problem????

After about an hour checking fuses and relays, I was none the wiser and we were ready for calling the breakdown service when the unexpected happened!

Yes, I stepped onto the battery cover in the cab and the dashboard lit up like a Christmas Tree.

Quickly taking up the carpet and removing the cover, I found that the fuses had come loose – why? I don’t know so a quick tighten up and hey presto, everything was alive.

The negative terminal was a little loose but this is down to the actual connector which I will replace as soon as I can but for the time being, we were back on the road.

 

The journey went well, we arrived in Calais in plenty of time for our ferry.

We parked up in line, switched off and when it came to our turn to board, it even started again – job done! or so we thought.

We parked right at the front of the ship, meaning we would be one of the first off in Dover and yes, you’ve guessed it, the bloody thing would not start.

A quick press down on the battery cover and away we went so I concluded that the actual problem was the loose negative terminal, not the fuses but not to tempt fate, I ordered a full replacement set and replaced them before our next adventure began.

So far, so good!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s